System Requirements

Browser Support

NCTracks content has been built using code compliant with World Wide Web Consortium (W3C) standards. Standards-compliant code allows NCTracks to be compatible with the majority of modern web browsers, and ensures forward compatible browser support.

For best results, we recommend using one of our fully supported browsers. See our supported browser list below. If you encounter a compatibility issue with a supported browser, please let us know.

Browser Vendor Version Update Link
Microsoft Internet Explorer 11 Internet Explorer
Mozilla Firefox * 49, 50 Mozilla Firefox
Google Chrome * 54, 55 Google Chrome
*Current and previous major release (These versions will change, possibly month to month). Major browser makers began a program, over 5 years ago, in which browsers can update themselves automatically to the most current major release. Google led this change and Mozilla quickly followed. Microsoft has yet to migrate all users to an Internet Explorer version that automatically updates to the most current major release.

NCTracks Secure Portal is designed for a minimum screen resolution of 1024x768.

Other Required Software

Adobe Reader

To view the Remittance Advice, letters, forms, Companion Guides, and other documentation, users will need to have Adobe Reader installed on their computer.  The minimum version required is Adobe Reader 9.5.

Java and Flash Player

To use all of the features of SkillPort, the NCTracks Learning Management System, users will need to have Java and Flash Player installed on their computer.  The minimum version requirements are:

  • Java/JRE 1.5
  • Flash Player 10.1

Microsoft Word and Excel

To view certain files on NCTracks, and to prepare files to upload to NCTracks, users may need to have Microsoft Word and Excel (or the equivalent open source software).  The minimum version required is Microsoft Office 2007.

Hardware and Connectivity

For the best portal experience, it is recommended that users access the NCTracks system using a high-speed internet connection and computers with a minimum of a Pentium 4+ processor or AMD equivalent.  The speed and reliability of the internet connection will affect the performance and response time experienced by users of the portal.